1783 | Promethean Support

1783 – ActivInspire does not start after latest macOS update

Applicable to:

  • ActivInspire

    ActivInspire

  • Mac

    Mac

If you have an older 32-bit version of ActivInspire installed on your Mac (prior to v2.15) and have recently updated it to the latest version of macOS, you will see the following error message when you launch ActivInspire:

“The ActivInspire app needs to be updated. The developer of this app must update it to work with this version of macOS. Contact the developer for more information.”

This is due to a change introduced in macOS Catalina (10.15). From macOS Catalina, 32-bit apps are no longer supported; macOS only supports 64-bit applications.

To start using ActivInspire again, you will need to download the latest version, which includes 64-bit support for macOS. Before installing it on your Mac, please ensure that you have uninstalled the previous version.

If you still need technical support, please contact us.