1722 - ClassFlow technical requirements | Promethean Support

1722 – What are the technical requirements for using ClassFlow?

Applicable to:

  • ClassFlow

    ClassFlow

ClassFlow is a browser-based application, so you only need a computer, a reliable Internet connection and a supported Internet browser.

ClassFlow is supported on the following browsers:

  • Google Chrome
  • Internet Explorer
  • Safari

We always recommend using the latest browser version, so it is good practice to check for updates regularly.

For an enhanced lesson-delivery experience, present your ClassFlow lessons on an interactive display, such as an ActivBoard or ActivPanel.

If you still need technical support, please contact us.